Wave Payments Impacted by 3rd party incident

Incident Report for Wave

Resolved

This incident has been resolved.
Posted Jun 24, 2025 - 09:22 EDT

Monitoring

Wave is currently impacted by an incident occurring with our Wave Payments partner, Worldpay. Clients of Wave users might receive error messages when they try to pay for Wave invoices. Further updates will be posted as new information becomes available.
Posted Jun 23, 2025 - 22:18 EDT
This incident affected: Payments.