Recurring Invoices Error
Incident Report for Wave
Resolved
The issue has been identified and resolved - users should be able to access Recurring Invoices without error going forward. We're sorry about the interruption today.
Posted Jan 30, 2023 - 14:55 EST
Investigating
We are currently investigating an issue that is preventing access to the Recurring Invoices feature. More updates to come, thank you for your patience.
Posted Jan 30, 2023 - 14:49 EST
This incident affected: Invoicing.