Investigating reports of Instant Payouts and Payments Onboarding failing

Incident Report for Wave

Resolved

The incident that caused Instant Payouts and Payments Onboarding to fail has been resolved.
Posted Mar 29, 2022 - 15:23 EDT

Identified

Users may continue to experience issues with Instant Payouts and Payments onboarding. We have identified the issue and are working on a resolution as soon as possible.
Posted Mar 29, 2022 - 13:55 EDT
This incident affected: Payments.