We're currently experiencing an issue with individuals trying to pay invoices via Apple Pay
Incident Report for Wave
Resolved
This incident has been resolved.
Posted Jun 22, 2022 - 19:08 EDT
Investigating
We are currently investigating the errors we're seeing when clients of our business owners are trying to pay invoices via Apple Pay. More updates on this to follow
Posted Jun 22, 2022 - 17:57 EDT
This incident affected: Payments.