Investigating reports of issues with in app page functionality

Incident Report for Wave

Resolved

This incident has been resolved.
Posted Aug 20, 2021 - 15:28 EDT

Investigating

We are currently investigating reports of some pages in app not functioning correctly. We sincerely apologize for any inconvenience and appreciate your patience.
Posted Aug 20, 2021 - 15:20 EDT
This incident affected: Web Application.