Investigating reports of login errors
Incident Report for
Wave
Resolved
We have resolved the issues that were affecting the sign in page.
Posted
Jun
01
,
2026
-
19:31
EDT
Identified
We are investigating reports that customers are unable to access Wave. Further updates to follow.
Posted
Jun
01
,
2026
-
18:46
EDT
This incident affected: Web Application, Accounting, Invoicing, Payments, and Payroll.
×
Subscribe to Incident
Subscribe to updates for
Investigating reports of login errors
via . You'll receive .