Page Loading Errors Across Wave

Incident Report for Wave

Resolved

The issue has been resolved. We apologize for the interruption to your Wave experience today.
Posted May 08, 2026 - 11:30 EDT

Investigating

We are investigating an issue that is causing login and page errors for some users across the Wave platform. We will share updates when they become available.
Posted May 08, 2026 - 10:43 EDT
This incident affected: Web Application, Accounting, Invoicing, Payments, Payroll, Receipts Processing, and Mobile Application.