Increased latency across the site
Incident Report for
Wave
Resolved
The latency issue has been resolved.
Posted
Jul
08
,
2025
-
17:08
EDT
Investigating
We are currently investigating increased levels of latency across the Wave platform. Some pages, such as logging in, may load slowly or lead to error messages.
Posted
Jul
08
,
2025
-
11:06
EDT
This incident affected: Web Application.
×
Subscribe to Incident
Subscribe to updates for
Increased latency across the site
via . You'll receive .