Instant Payouts and Wave Payments Onboarding
Incident Report for Wave
Resolved
Thank you for your patience. New Instant Payouts and new Wave Payments accounts are now functioning as expected. We apologize for the inconvenience.
Posted Aug 30, 2021 - 20:24 EDT
Update
We are continuing to investigate the issue that is affecting Instant Payouts as well as Wave Payments onboarding.
Posted Aug 30, 2021 - 17:43 EDT
Update
We are continuing to investigate the issue that is affecting receiving Instant Payouts and onboarding to Wave Payments.
Posted Aug 30, 2021 - 16:28 EDT
Investigating
We are currently investigating an issue that is affecting receiving Instant Payouts and onboarding to Wave Payments. We will keep you posted with updates - thanks for your patience.
Posted Aug 30, 2021 - 15:51 EDT
This incident affected: Payments.