Reports out-of-sync for some businesses

Incident Report for Wave

Resolved

The issue has been resolved, and the impacted reports should be loading as expected. Thank you for your patience in this matter.
Posted Dec 01, 2025 - 17:27 EST

Update

We have identified the issue that is causing inaccurate reports for some business owners in Wave, and we are continuing to implement a solution to those impacted. We are sorry for the errors and will share an update as soon as possible.
Posted Dec 01, 2025 - 15:05 EST

Identified

We have identified an issue that is causing inaccurate reports for some business owners in Wave. We are working on a solution and apologize for the technical interruption.
Posted Dec 01, 2025 - 12:25 EST
This incident affected: Accounting.