Receipts not processing

Incident Report for Wave

Resolved

This incident has been resolved now. The receipts that were stuck in processing have now been successfully processed.
Posted Jan 28, 2026 - 12:02 EST

Investigating

We are currently investigating the receipts feature not processing uploads. We apologize for the inconvenience and will provide updates as they become available.
Posted Jan 28, 2026 - 11:58 EST
This incident affected: Receipts Processing.