Check Deposit Unavailable
Incident Report for Wave
Resolved
This issue has been resolved. Checks can now be deposited again via the Wave Money app.
Posted Aug 17, 2021 - 18:37 EDT
Identified
The issue impacting Wave Money check deposits has been identified and we are working to resolve the issue.
Posted Aug 17, 2021 - 17:22 EDT
Investigating
We are currently investigating an issue with check deposit for Wave Money. At this time, check deposit is not available.
Posted Aug 17, 2021 - 16:27 EDT
This incident affected: Wave Money.