Wave dashboard display errors
Incident Report for Wave
Resolved
We have resolved the issue that was impacting the Wave dashboard and it should be once again functioning as expected. If you are still having trouble loading your dashboard please try refreshing the page.
Posted Apr 27, 2021 - 22:14 UTC
Investigating
We are currently investigating reports that the Wave Dashboard is not loading. Please note that the rest of your Wave account should be functioning as expected and we will provide further updates once they become available.
Posted Apr 27, 2021 - 22:08 UTC
This incident affected: Web Application.