Some customer payments affected by processing delay
Incident Report for Wave
Resolved
This incident has been resolved.
Posted Aug 04, 2021 - 15:50 UTC
Update
We are continuing to work on a fix for this issue.
Posted Aug 04, 2021 - 15:14 UTC
Update
We are continuing to work on a fix for this issue.
Posted Aug 04, 2021 - 13:59 UTC
Identified
Some customers may be affected by a payments processing error, causing payouts to be delayed. If you are impacted by this delay you will be receiving an update from our team shortly with further details relevant to your account.
Posted Aug 04, 2021 - 13:37 UTC
This incident affected: Payments.